Disney Chat

End Chat

STAR WARS™: Commander

  • Android
  • Facebook Gameroom
  • Windows
  • iOS

What are the minimum requirements needed to play?

posted on 2017/08/16


If your device meets these requirements, you should be able to play STAR WARS™: Commander without issue.

NOTE: This game requires an Internet connection to play


Requirements for Android devices
  • Android OS 4.2 and later
For steps on updating your Android software, please click here.
 

Requirements for iOS devices
  • iPhone 4S and later, iPad 2 and later (including iPad mini)
  • iOS 8.0 or later
    • Recommended: iPhone 5/5s/5c, and iPad 4 and later running iOS 8.0 or later
For steps on updating your iOS software, please click here.


Requirements for Facebook Gameroom
  • Facebook account
  • PC: Windows 7 and above


Helpful Links
  • Click here for a link to the App Store
  • Click here for a link to Google Play
  • Click here for a link to Facebook Gameroom
     
 

Was this article helpful?


Still looking for the right answer?

Contact Us