Disney Chat

End Chat

LEGO® STAR WARS™ II: The Original Trilogy

  • Console
  • Mac

What are the system requirements for LEGO STAR WARS™ II: The Original Trilogy?

posted on 2014/07/23


 

PC

What are the system requirements for LEGO STAR WARS™ II?
LEGO STAR WARS™ II for PC requires the following minimum system requirements:

Operating System
Required: Windows 2000, XP, or Vista
Computer
Required: 100% DirectX 9.0c compatible computer
CPU
Required: Intel P3 1.0 GHz or AMD Athlon 1000 MHz; Recommended: Intel P4 2.0 GHz or AMD Athlon XP 2400+
Memory
Required: 256 MB RAM; Recommended: 512 MB RAM
Graphics Card
Required: 64 MB 3D Graphics card with Vertex and Pixel Shader (VS/PS) Capability; Recommended: 128 MB 3D Graphics card with Vertex and Pixel Shader (VS/PS) Capability
Sound Card
Required: 100% DirectX 9.0c compatible Audio Device
CD-ROM
Required: 8X Speed CD-ROM drive; Recommended: 16X Speed CD-ROM or DVD-ROM drive
Input Device
Required: Keyboard and mouse. Gamepad and joystick supported; Recommended: Gamepad
DirectX
Microsoft DirectX 9.0c (April 2006 Edition) is included on this CD. You will be prompted to install DirectX during the installation of this game if this or a more recent version is not already properly installed on your system.
NOTE: DirectX may require the "latest" updates for your operating system. This may also include the latest drivers for your motherboard, sound, and video hardware.

Installation: Installation requires 3.5 GB of free hard drive space. We recommend that you have an additional 500 MB of free space available after installing the game for the Windows swap/page file.

You must have local Administrator rights to properly install LEGO STAR WARS™ II and update DirectX. 

What video cards are NOT supported in LEGO STAR WARS™ II: The Original Trilogy?
Ahe following 3D chipsets do not meet the minimum specification necessary to play LEGO STAR WARS™ II:

3D Labs GLINT R3/R4
3dfx Voodoo Graphics (Voodoo 1), Voodoo 2/3/4/5, Voodoo Banshee, Voodoo Rush
#9 Ticket to Ride/IV
ATI 3D Rage II, Rage Pro/LT Pro, Radeon 7000 VE, Radeon 7200/7500
Intel i740/i810/i845/i865
Matrox G100/200/4xx/5xx
Mpact 2
NVIDIA GeForce 256, GeForce 2, GeForce 2 MX, GeForce 2 MX 200/400, GeForce 4 MX
NVIDIA RIVA 128/128 ZX, RIVA TNT/TNT2
Permedia 2/3
PowerVR Kyro/Kyro II, Neon 250, PCX/PCX-2
Rendition V1000/V2x00
S3 Savage 3D/2000/Pro, ViRGE/DX/GXx/VX
SiS 315, 6326, Xabre200/400/600
Trident 3D Image 9x5, Blade3D 9880, BladeXP T64
Matrox Parhelia-512, Millennium P750
XGI Volari V5 Ultra

Some of the chipsets listed directly above may work with future drivers. Please check for updated drivers for these cards, which may address the issues that prohibited these chipsets from being supported at the time of release of this title.


Are there any options LEGO STAR WARS™ II: The Original Trilogy to brighten the game?
There are no in-game options to brighten the game.

I am experiencing issues with LEGO STAR WARS™ II: The Original Trilogy on a dual core processor system.
If you're experiencing random graphics issues in LEGO STAR WARS™ II: The Original Trilogy on a dual core system (such as camera focusing somewhere else and getting stuck, etc), try setting the Affinity:

1. Right after launching the program, open the Task Manager.
2. Choose the Processes tab.
3. Right-click on the LegoStarWarsII.exe process and choose Set Affinity.
4 Select which CPU to use, and choose OK.

Low-end Graphics Card Issues
When using a low-end graphics card, you may experience the following issues when playing the game:
  • Performance may be slow in some areas.
  • You may see flickering graphics.
  • Textures may be missing or they may display incorrectly.
  • You may experience poor performance or lock ups after selecting any Screen Resolution above 1024x768. If this occurs, we recommend that you select a lower resolution.
LEGO STAR WARS™ II Update
The update for LEGO STAR WARS™ II: The Original Trilogy that addresses the following issues:

This update for the game has been modified to:
  • Address an error that is seen on some systems during installation.
  • Address controller customization issues with certain gamepads
  • Address the missing "jump" ability for Danish version
  • Update the User Interface
Instructions for Installing this Update
---------------------------------------
When you run the appropriate file for your country, which is noted below, this update may prompt you to insert the original game disc in your drive if it is not already in the drive. After you insert the disc, just follow the prompts to install LEGO® STAR WARS II: THE ORIGINAL TRILOGY.
United Kingdom/France/Italy/Germany/Spain/Denmark/Australia
LEGO STAR WARS Installer Patch v1.0.2_EFIGSD.exe
NOTE: This update incorporates all previous updates.
Why Can't I Get the Launcher to Respond?
This problem may be caused by several factors:
  • The STAR WARS™ Battlefront II CD may have been removed.
  • Your CD-ROM drive may have stopped responding.
  • There may be a hardware conflict in your system.
  • The STAR WARS™ Battlefront II CD may be scratched or dirty.
  • Your computer may not be 100% DirectX 9.0c compatible.
What are the supported video cards / chipsets for LEGO STAR WARS™ II: The Original Trilogy?
Below is a list of the video cards and chipsets that are supported in LEGO STAR WARS™ II. If you do not see your card listed, but you do see a chipset that matches the one used on your card, you should be able to play LEGO STAR WARS™ II.

NOTE: Some of the following cards will work with LEGO STAR WARS™ II, but exhibit certain issues. When using any of these cards and chipsets, you should be using the latest drivers for your card unless noted.

Supported Card and Video Driver List
Windows 2000
Chipset Driver Version #
ATI Radeon 8500 through 9200 Catalyst 6.2 6.14.0010.6599
ATI Radeon 9500 through 9800 Catalyst 6.2 6.14.0010.6599
ATI Radeon X300 through X800 Catalyst 6.2 6.14.0010.6599
ATI Radeon X1300 through X1800 Catalyst 6.2 6.14.0010.6599
Intel 915G and 945G Win2k_XP1420 6.14.0010.4543
NVIDIA GeForce 3 through GeForce 4 Ti ForceWare 91.31 6.14.0010.9131
NVIDIA GeForce FX 5100 through 5950 ForceWare 91.31 6.14.0010.9131
NVIDIA GeForce PCX 5300 through 5900 ForceWare 91.31 6.14.0010.9131
NVIDIA GeForce 6100 through 6800 ForceWare 91.31 6.14.0010.9131
NVIDIA GeForce 7300 through 7950 ForceWare 91.31 6.14.0010.9131
S3Graphics Chrome S27 S3G_ChromePCIe_wxp2k_v151910h 6.14.0010.2267
S3Graphics GammaChrome S4 Nitro S3 ComboChrome 15.16.14j 6.14.0010.2021
S3Graphics GammaChrome S18 Ultra S3G_ChromePCIe_wxp2k_v151805m 6.14.0010.2217

Windows XP
Chipset Driver Version #
ATI Radeon 8500 through 9200 Catalyst 6.7 6.14.0010.6626
ATI Radeon 9500 through 9800 Catalyst 6.7 6.14.0010.6626
ATI Radeon X300 through X800 Catalyst 6.7 6.14.0010.6626
ATI Radeon X1300 through X1800 Catalyst 6.7 6.14.0010.6626
Intel 915G and 945G Win2k_XP1420 6.14.0010.4543
NVIDIA GeForce 3 through GeForce 4 Ti ForceWare 91.31 6.14.0010.9131
NVIDIA GeForce FX 5100 through 5950 ForceWare 91.31 6.14.0010.9131
NVIDIA GeForce PCX 5300 through 5900 ForceWare 91.31 6.14.0010.9131
NVIDIA GeForce 6100 through 6800 ForceWare 91.31 6.14.0010.9131
NVIDIA GeForce 7300 through 7950 ForceWare 91.31 6.14.0010.9131
S3Graphics Chrome S27 S3G_ChromePCIe_wxp2k_v151910h 6.14.0010.2267
S3Graphics GammaChrome S4 Nitro S3 ComboChrome 15.16.14j 6.14.0010.2021
S3Graphics GammaChrome S18 Ultra S3G_ChromePCIe_wxp2k_v151805m 6.14.0010.2217

Windows Vista
Chipset
ATI Radeon 9500 through 9800, Radeon X300 through X800, Radeon X1300 through X1800
Intel 915G and 945G
NVIDIA GeForce FX 5100 through 5950, GeForce PCX 5300 through 5900, GeForce 6100 through 6800, GeForce 7300 through 7950
S3Graphics Chrome S27, GammaChrome S4 Nitro, GammaChrome S18 Ultra

When I try to start the game, I get a message, "Conflict with Disc Emulation Software detected. See www.securom.com/emulation for more details" or "Wrong Volume in drive"
Information and troubleshooting steps for this error can be found here.



top

 

Digital Download

Do the digital download versions of the games from Steam or Direct2Drive include all the updates?
Yes, all the older titles being released through Steam and Direct2Drive include all available patches or updates. Note that unless indicated, they do not include any expansions or plugins.



top

 

 

Was this article helpful?


Still looking for the right answer?

Contact Us

We recommend contacting us by

Email

Other ways to contact

Logo

Call Me Now

Logo

Free Phone